기록하는 개발자

[백준 2920번] 음계- JAVA 알고리즘 본문

Baekjoon Online Judge

[백준 2920번] 음계- JAVA 알고리즘

gitseok 2022. 6. 8. 16:36

2920번
문제
다장조는 c d e f g a b C, 총 8개 음으로 이루어져있다. 이 문제에서 8개 음은 다음과 같이 숫자로 바꾸어 표현한다. c는 1로, d는 2로, ..., C를 8로 바꾼다.
1부터 8까지 차례대로 연주한다면 ascending, 8부터 1까지 차례대로 연주한다면 descending, 둘 다 아니라면 mixed 이다.
연주한 순서가 주어졌을 때, 이것이 ascending인지, descending인지, 아니면 mixed인지 판별하는 프로그램을 작성하시오.
입력
첫째 줄에 8개 숫자가 주어진다. 이 숫자는 문제 설명에서 설명한 음이며, 1부터 8까지 숫자가 한 번씩 등장한다.
출력
첫째 줄에 ascending, descending, mixed 중 하나를 출력한다.
예제 입력 예제 출력
   
1 2 3 4 5 6 7 8

8 7 6 5 4 3 2 1

8 1 7 2 6 3 5 4
ascending

descending

mixed

 

import java.io.BufferedReader;
import java.io.BufferedWriter;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
import java.text.ParseException;
import java.util.StringTokenizer;


public class Main {

	public static void main(String[] args) throws IOException, ParseException {
		// TODO Auto-generated method stub
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in)); // 선언
		BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out)); // 선언
		
		
		StringTokenizer st = new StringTokenizer(br.readLine());	
		
		int now = Integer.parseInt(st.nextToken()); //첫번째 값 저장
		int ascending = 0;
		int descending= 0;
		
	
		for (int i = 2; i <= 8; i++) {
			int num = Integer.parseInt(st.nextToken());
			
			if (num > now) { //이전 수와 현재 수 비교
				ascending = 1; //커졌다면 ascending 에 기록
			} else {
				descending = 1; //작아졌다면 descending에 기록
			}
			now = num; //현재 수 저장
		}	
		
		if(ascending==1 && descending ==1) { //섞여있다면 mixed
			bw.write("mixed");
		}else if(ascending==1) { 	// 오름차순이라면
			bw.write("ascending");
		}else {						// 나머지(내림차순이라면)
			bw.write("descending"); 
		}
		
		bw.close();
		br.close();
	}
}

실행 결과

개인적으로 정리한 내용을 간단하게 풀어 작성했습니다.
이해가 안가는 부분은 댓글 남겨주시면 설명해드리겠습니다.
Comments